Problème de latence

Bonjour,

je suis relativement neuf dans l’utilisation de vos services dont le vpn mais j’en utilise d’autres et j’ai pu remarquer qu’à certains moments comme cette nuit j’ai du 300 de ping sur l’adresse ip de cloudflare pour monitoring de la connexion vpn que j’ai mis en place.+ aussi un certain pourcentage de perte de paquets, +/- 10%
Sur du parefeu opnsense virtualisé.
une idée? o ubien c’est normal et c’est en fonction de l’utilsation de votre vpn par l’ensemble du groupe?

Exemple durant cette après midi j étais à 5% de perte de paquets avec un Ping oscillant entre 40 et 70 sur les dns cloudflare.
Ce soir re-belotte je suis de nouveau à 100 voir 200 de Ping et 300 en Rttd avec 15% de perte de paquets.

Mes autres liens vpns sont normaux et l utilisation processeur n est clairement pas en cause

Bonsoir boistordu,

Bonne remarque, j’ai effectivement remarqué ça dernièrement.
Je ne saurais te dire de quoi ça vient pour l’instant… :thinking:
Je vais garder un oeil là dessus.

@igel
Voilà donc test effectués ça vient bien de cogent et puis d’au-delà.
je te mets un lien vers un de mes hastebin pour le copier coller des traceroute
et je te mets ici un traceroute normal vers là même ip qui finit donc en allemagne.

traceroute to 4.2.2.1 (4.2.2.1), 30 hops max, 60 byte packets
 1  _gateway (192.168.2.161)  0.268 ms  0.220 ms  0.207 ms
 2  192.168.0.1 (192.168.0.1)  1.548 ms  1.838 ms  2.803 ms
 3  10.24.1.18 (10.24.1.18)  6.295 ms  6.743 ms  8.733 ms
 4  * * *
 5  ae-60-100.ibrstr5.isp.proximus.be (91.183.241.168)  9.199 ms  9.357 ms  9.600 ms
 6  8-2-1.bear1.Brussels1.Level3.net (213.242.124.25)  9.422 ms  9.086 ms  9.605 ms
 7  ae-2-3207.edge5.Frankfurt1.Level3.net (4.69.163.22)  18.678 ms  15.136 ms  15.513 ms
 8  a.resolvers.level3.net (4.2.2.1)  16.018 ms  15.076 ms  16.250 ms

Donc ici tu peux constater que j’ai à chaque fois donc mes 3 ping à chaque fois.

autre traceroute à partir de neutrinet cette fois-ci:

> traceroute to 4.2.2.1 (4.2.2.1) from 80.67.181.153, 64 hops max, 40 byte packets
>  1  vpn.neutri.net (80.67.181.129)  19.051 ms  20.292 ms  23.081 ms
>  2  edge-01.blue.neutri.net (80.67.181.2)  21.203 ms  22.255 ms  22.386 ms
>  3  edg01.blutw.bra.be.verixi.net (62.112.29.90)  23.629 ms  20.523 ms  22.020 ms
>  4  te0-0-0-12.edg01.lcldg.bra.be.verixi.net (62.112.29.164)  22.674 ms  21.313 ms  21.628 ms
>  5  xe-8-0-1.bar2.Brussels1.Level3.net (212.3.237.253)  20.913 ms  21.979 ms  22.669 ms
>  6  ae-2-3207.edge5.Frankfurt1.Level3.net (4.69.163.22)  31.182 ms  31.945 ms  35.996 ms
>  7  a.resolvers.level3.net (4.2.2.1)  30.182 ms  29.297 ms  29.776 ms

toujours mes 3 pings à chaque fois.

Mais comme tu le verras ici
tu verras qu’à partir du noeud de cogent

154.54.59.133

et

154.54.56.190

ça commence à foirer .

Malheureusement ce soir sur le traceroute, même si j’avais de forte latence sur le monitoring ça se ressentais pas trop sur le traceroute à part de temps en temps genre des hausses à 900 de ping .
Non ce qui est plus problématique c’est l’absence d’une grande partie des paquets ICMP sur les résultats. Alors que je les ai sur les autres réseaux. Je crois peu au problème du edge de Frankfurt donc c’est que c’est bien au niveau de cogent que ça coince.
Après je ne sais pas quel est votre contrat avec eux mais donc pour moi ça me paraît du coup assez évident.
Merci en tout cas de m’avoir pointé vers cette direction parce que c’est vrai que j’y avais pas réfléchi.

traceroute to 4.2.2.1 (4.2.2.1) from 89.234.141.56, 64 hops max, 40 byte packets
1 vpn-end.arn-fai.net (89.234.141.1) 27.995 ms 28.285 ms 28.038 ms
2 hwhost-2.arn-fai.net (89.234.141.132) 28.107 ms 28.049 ms 28.391 ms
3 gi0-6-0-19.203.rcr21.sxb01.atlas.cogentco.com (149.11.26.41) 29.282 ms 29.189 ms 28.999 ms
4 be3546.ccr41.fra03.atlas.cogentco.com (154.54.59.33) 33.503 ms
be3548.ccr42.fra03.atlas.cogentco.com (154.54.59.133) 31.030 ms
be3546.ccr41.fra03.atlas.cogentco.com (154.54.59.33) 31.562 ms
5 be2845.rcr22.fra06.atlas.cogentco.com (154.54.56.190) 32.108 ms 32.775 ms
be2846.rcr22.fra06.atlas.cogentco.com (154.54.37.30) 32.704 ms
6 lag-23.ear3.Frankfurt1.Level3.net (4.68.111.177) 32.085 ms 31.647 ms 32.013 ms
7 ae-2-3207.edge5.Frankfurt1.Level3.net (4.69.163.22) 32.182 ms
ae-1-3107.edge5.Frankfurt1.Level3.net (4.69.163.18) 31.739 ms
ae-2-3207.edge5.Frankfurt1.Level3.net (4.69.163.22) 32.210 ms
8 a.resolvers.level3.net (4.2.2.1) 31.545 ms 31.842 ms 33.491 ms
■■■■■■■■■■■■■:~ # traceroute -s ‹ 89.234.141.56 › 4.2.2.1
traceroute to 4.2.2.1 (4.2.2.1) from 89.234.141.56, 64 hops max, 40 byte packets
1 vpn-end.arn-fai.net (89.234.141.1) 27.856 ms 27.994 ms 27.689 ms
2 hwhost-2.arn-fai.net (89.234.141.132) 28.275 ms 28.247 ms 28.472 ms
3 gi0-6-0-19.203.rcr21.sxb01.atlas.cogentco.com (149.11.26.41) 29.168 ms 28.833 ms 29.062 ms
4 be3548.ccr42.fra03.atlas.cogentco.com (154.54.59.133) 32.215 ms
be3546.ccr41.fra03.atlas.cogentco.com (154.54.59.33) 31.896 ms 32.677 ms
5 be2846.rcr22.fra06.atlas.cogentco.com (154.54.37.30) 32.469 ms 32.408 ms
be2845.rcr22.fra06.atlas.cogentco.com (154.54.56.190) 32.463 ms
6 lag-23.ear3.Frankfurt1.Level3.net (4.68.111.177) 31.832 ms 31.541 ms
ae-8.edge8.Frankfurt1.Level3.net (4.68.37.93) 32.253 ms
7 ae-1-3107.edge5.Frankfurt1.Level3.net (4.69.163.18) 32.478 ms
ae-2-3207.edge5.Frankfurt1.Level3.net (4.69.163.22) 32.357 ms
ae-1-3107.edge5.Frankfurt1.Level3.net (4.69.163.18) 31.726 ms
8 a.resolvers.level3.net (4.2.2.1) 31.842 ms 32.049 ms 31.767 ms

J annonce que la maintenant tout de suite, ke lien vpn et un traceroute effectué dessus se comporte désormais comme il devrait se comporter donc plus de latence au niveau de cogent.

Ce n’est peut-être que spécifique à cette heure-ci mais là en tout cas ça fonctionne comme ça doit:) je regarderai si la situation se dégradé ou pas par la suite.

Et maintenant à 15h07 je peux voir que la latence est de nouveau remontée à des niveaux satellitaires. Ce aue je ne comprends pas c edt pourquoi cogent semble avoir tellement de soucis à maintenir un QOS acceptable alors que les autres providers en Europe y arrivent vraisemblablement.