[Bug] Libreto

J’aimerais utiliser libreto avec une instance qui a la dernière version d’etherpad ce qui n’est malheureusement pas le cas de la notre.

Peu importe l’instance personnalisée que je sélectionne j’obtiens cette erreur :

Je dirais que ça me parait logique.
Tu essaie d’accéder à un sous-domaine de sans-nuage qui n’existe pas et qui n’as pas de certificat. Donc si le serveur est bien configuré il ne te laisse pas passer.

1 J'aime

Voilà toutes les étapes :

Ok tout s’explique.
En fait tu essaie de créer une sous instance personnalisé de libreto mais avec un autre nom de domaine. En fait cette option n’a pas beaucoup de sens puisque https://libreto.sans-nuage.fr/ est déjà une instance de libreto et que n’importe qui peut créer son propre libreto sur sans-nuage.

Après je pense rien ne s’oppose au fait de linker des pads dans le libreto qui ne sont pas chez sans-nuage. Faudrait tester.

J’ai testé et ça fonctionne :slight_smile: : https://libreto.sans-nuage.fr/costrasbourg !
J’ai même réussis à appliquer une feuille de style personnalisée.

Par contre deux choses ne fonctionne pas : Exporter et Télécharger

En image :

C’est effectivement un bug de libreto ou de notre instance puisque ça ne fonctionne pas non plus avec les pad hébergé par sans-nuage. Je viens de faire le test avec le libreto educ-pop, même résultat que toi.

1 J'aime

Après discussion avec le développeur, j’ai déclaré ces bugs sur son github : https://github.com/Ventricule/libreto/issues

1 J'aime

En fait je pense que c’est un peu lié au package yunohost… Le trucs c’est que pour faire fonctionner ce trucs il faut installer autant de sous-domaines dans yunohost, ce qui n’est peut être pas très pratique faudrait affiner le paquet.